Ask Your Question
0

User with uid lower than 1000 showing in GDM user list.

asked 2013-11-21 15:38:35 -0600

sudormmiusrf gravatar image

I created a user on my system for a local scanner to use call s2f

when i created it I used the command

useradd -r s2f # to create it as a system account

I can check that user got a uid lower than 1000

[me@mpc ~]$ cat /etc/passwd | grep s2f

s2f:x:990:985::/home/s2f:/bin/bash

but the user shows in GDM user list and in the gui user account editor. UID_MIN is set to 1000

/etc/login.defs

[me@pc ~]$ cat /etc/login.defs | grep UID_MIN
UID_MIN                  1000
SYS_UID_MIN               201

Any one why this is happening?

edit retag flag offensive close merge delete

Comments

Try to set SYS_UID_MIN to 999.

lzap gravatar imagelzap ( 2013-11-22 01:58:17 -0600 )edit

I am not suggesting this as a solution but if this is not a real user then also consider setting the login shell to /sbin/nologin. Maybe other atributes are also used to determine whether someone is a real user or a system user

domg472 gravatar imagedomg472 ( 2013-11-22 07:45:04 -0600 )edit

@domg472 Yeah that fixed it, thanks, please repost as an answer.

sudormmiusrf gravatar imagesudormmiusrf ( 2013-11-22 09:44:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-25 13:31:42 -0600

domg472 gravatar image

Set the login shell to /sbin/nologin so that gdm can determine that this is not a valid login user

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-21 15:38:35 -0600

Seen: 494 times

Last updated: Nov 25 '13