Ask Your Question
1

How to change userid to 500 from 1000?

asked 2011-11-08 21:03:33 -0500

mjmwired gravatar image

updated 2014-09-28 15:41:50 -0500

mether gravatar image

I have multiple Fedora and Centos installs with my userid at 500. In order to access my NFS shares I reverted the 1000 to 500 in /etc for my user id (passwd, group). I also 'chown -R' my /home directory.

Did I miss something?

GDM no longer lists my login name. I have to keep clicking "Not listed". Why not just show a prompt instead. I know now I should have specified a userid when I installed (but I didn't realize it). The current setup seems like a bad design.

EDIT: Changing /etc/login.defs for UIDMIN or GIDMIN has no effect.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-11-09 00:49:40 -0500

Guest gravatar image

Change UIDMIN and GIDMIN parameter values to 500 in /etc/login.defs file. If you have already created user and want change uid for user, Edit /etc/passwd file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-08 21:03:33 -0500

Seen: 3,170 times

Last updated: Nov 09 '11