Ask Your Question
0

livecd-creator: Livecd fails to boot [closed]

asked 2011-10-02 01:00:00 -0500

sagarun gravatar image

updated 2011-10-02 14:42:12 -0500

I am trying to roll out this live cd,

Here are the kickstart files, http://sagarun.fedorapeople.org/misc/fedora-schools.ks http://sagarun.fedorapeople.org/misc/fedora-live-base.ks

After creating the livecd in one of the Fedora test machines, I tried to boot the ISO which is x86_64 Fedora live in my X86 32 bit Fedora 15 host using kvm and virtualbox,

Both resulted in http://sagarun.fedorapeople.org/misc/sysfs_screenshot.png

Update 1

As @mether suggested , i have removed all updates repositories from the kickstart file. Updated ks files are available at the same location.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2014-07-14 09:18:06.930925

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-02 23:25:27 -0500

sagarun gravatar image

updated 2011-10-12 14:58:02 -0500

I mixed up ks from F14 and F15 , I got it solved after some one from livecd list spotted it https://lists.fedoraproject.org/pipermail/livecd/2011-October/006910.html

Thanks. Sorry for the trouble!

edit flag offensive delete link more
0

answered 2011-10-02 01:06:30 -0500

mether gravatar image

Does the live image you generate includes updates? If so, try without that.

edit flag offensive delete link more

Comments

Yea, It includes the latest updates. They are breaking stuff since F13 in updates :(

sagarun gravatar imagesagarun ( 2011-10-02 01:14:28 -0500 )edit

@mether , I commented out all the updates repos. Strange it still complains of same exception

sagarun gravatar imagesagarun ( 2011-10-02 14:20:48 -0500 )edit

did you try what @shanks suggested? You might go with Fedora 16 as the basis for the remix anyway considering the schedule

mether gravatar imagemether ( 2011-10-02 14:37:27 -0500 )edit

@mether, i tried @shanks suggestions, didn't work. Ok let me try F16.

sagarun gravatar imagesagarun ( 2011-10-02 14:44:10 -0500 )edit
0

answered 2011-10-02 01:43:27 -0500

shanks gravatar image

updated 2011-10-12 14:56:19 -0500

sagarun gravatar image

I suspect this is related to bug#713031

"This is because the entry in /etc/fstab (1st field) does not match with the way how /sys was mounted."

/etc/fstab (generated by anaconda):

sysfs      /sys     sysfs   defaults        0 0
^^^^^

/proc/mounts (probably mounted by dracut):

/sys      /sys      sysfs   rw,relatime 0 0 
^^^^

Try setting

mount -t sysfs -o nosuid,noexec,nodev /sys /sys >/dev/null 2>&1

to

mount -t sysfs -o nosuid,noexec,nodev sysfs /sys >/dev/null 2>&1

in /usr/share/dracut/modules.d/99base/init and then try creating the live cd.

.

Update 1:

Firstly in %post section you may add:

cp /etc/fstab /etc/fstab.orig
sed -i -e '0,/RE/s/sysfs/\/sys /' /etc/fstab

and if that doesn't work then ... try replacing the above in %post with:

cp /usr/share/dracut/modules.d/99base/init /usr/share/dracut/modules.d/99base/init.orig
sed -i -e 's/nodev \/sys/nodev sysfs/' /usr/share/dracut/modules.d/99base/init
edit flag offensive delete link more

Comments

How do i do it in a kickstart file?

sagarun gravatar imagesagarun ( 2011-10-02 01:49:57 -0500 )edit

What about replacing /proc with 'proc'? In the bug they have done that too!

sagarun gravatar imagesagarun ( 2011-10-02 08:40:34 -0500 )edit

@shanks Tried executing the scripts in post section. Still the livecd doesn't boot with the same error. I also checked /usr/share/dracut/modules.d/99base/init from runlevel1, The script indeed modfied the file.

sagarun gravatar imagesagarun ( 2011-10-02 12:28:25 -0500 )edit

Question Tools

Stats

Asked: 2011-10-02 01:00:00 -0500

Seen: 518 times

Last updated: Oct 12 '11